What are the system requirements to use the SAO?

The following systems and browsers are supported:PC(Windows version 7,8,10) Chrome: We recommend at least version 51,52Firefox: We recommend at least version 47,48Microsoft Internet Explorer: Version 11Mac (OS:10.11 El Capitan and 10.12 Sierra)Safari: Version 8,9Chrome: We recommend at least version 51,52Firefox: We recommend at least version 47,48Regardless of browser, please make sure the following browser settings are correct:Javascript must be enabled.Cookies must be enabled.Other Software needed:To view and print PDF files, we recommend Adobe Acrobat Reader (latest version). While PDF files should work with most other PDF viewers, we can only guarantee full compatibility and support with Adobe Acrobat Reader.

The following systems and browsers are supported:

PC(Windows version 7,8,10)

  • Chrome: We recommend at least version 51,52
  • Firefox: We recommend at least version 47,48
  • Microsoft Internet Explorer: Version 11

Mac (OS:10.11 El Capitan and 10.12 Sierra)

  • Safari: Version 8,9
  • Chrome: We recommend at least version 51,52
  • Firefox: We recommend at least version 47,48

Regardless of browser, please make sure the following browser settings are correct:

  • Javascript must be enabled.
  • Cookies must be enabled.

Other Software needed:

To view and print PDF files, we recommend Adobe Acrobat Reader (latest version). While PDF files should work with most other PDF viewers, we can only guarantee full compatibility and support with Adobe Acrobat Reader.

Was this helpful?
How can we improve?
Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.
Basics